How can we help?

How to Configure Syslog on a Mikrotik Router

Follow

These instructions assume:

  • The date, time and time zone are correctly set on the router.
  • You have access to the Mikrotik router via either the command line (Telnet or SSH) or the web management interface.
  • You have the IP address of your Auvik collector.

Option 1 - command line

  1. Telnet or SSH into your router.
  2. Run the command
    /system logging action
  3. And then run
    print
  4. You must have a line called “remote” where you set the IP address of the syslog server; run the following command to edit the remote IP address to your Auvik collector IP address,
    set [find name=remote] remote=AuvikCollectorIP
  5. Once that is done, issue a print command to confirm if the remote IP address was saved as desired, and confirm that remote-port is set to 514.
  6. Next, edit the syslog type information to send the messages to the remote configuration that was just configured. For that, run the command
    /system logging
    and then
    print
    This is the expected result:
    Screen_Shot_2021-03-18_at_11.22.54_AM.png

  7. Use the numbers next to the topics listed by your Mikrotik to run the next command, according to the log severity you want to send to Auvik. In the example below, all log messages will be sent:
    set action=remote 0,1,2,3
  8. Then run the print command to verify the action settings were changed to “remote”.

Option 2 - web interface

  1. Go to System, Logging, and then Actions.
  2. Select remote.
  3. In the remote address, add the Auvik collector IP address.
  4. Make sure the remote port is set to 514.
  5. Click OK to save the configuration.
  6. Then go to System, Logging, and Rules.
  7. Change the syslog message types that you would like to send to Auvik by selecting them and changing the associated action to remote. If you are sending all the logs to Auvik, it should look like this:

Screen_Shot_2021-03-18_at_11.23.01_AM.png

 

Once that’s done, your Mikrotik router should be sending the syslog information to the Auvik collector.

 

For more information: https://wiki.mikrotik.com/wiki/Manual:System/Log

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request