How can we help?

How do I troubleshoot issues with my Auvik / Opsgenie integration?

Follow

There are a few possible issues you might experience when integrating Auvik with Opsgenie:

Testing the connection produces a fail message

Scenario

After setting the integration details for a new Auvik / Opsgenie integration, you clicked Test Connection. You received a fail message.

Solution

The first thing to check is whether the Opsgenie URL is correct. To do this, confirm the Opsgenie URL from your Opsgenie configuration. If the URL doesn’t match the Opsgenie configuration, update it. Click Test Connection again.

If Test Connection passes, you’ll see a success message in Auvik.

If Test Connection still produces a failure after confirming the Opsgenie URL is correct, please contact Auvik support.

New Auvik alerts aren’t appearing in Opsgenie

Scenario

Alerts triggered in Auvik aren’t being sent to Opsgenie

Solution

The first thing to check is whether the Opsgenie URL is correct. To do this, confirm the Opsgenie URL from your Opsgenie configuration. If the URL doesn’t match, update it. Click Test Connection again.

If Test Connection still produces a failure after confirming the Opsgenie URL is correct, please contact Auvik support.

 

Alerts aren’t clearing in either Opsgenie or Auvik

Scenario

An alert opened in Auvik has been sent to Opsgenie, but after closing the ticket in either system, the other application isn’t being updated.

Solution

The first thing to check is whether the Auvik username, API key, and Auvik URL you entered in Opsgenie are correct. If any are incorrect, make corrections in Opsgenie.

If this doesn’t resolve the issue, confirm that the Opsgenie URL you entered in Auvik matches your Opsgenie instance. If it doesn’t match, update the Opsgenie URL in Auvik and click Test Connection to make sure it’s working correctly.

 

Another thing to confirm in Auvik is that the Opsgenie notification channel is still associated with the alerts. If the notification channel is no longer linked to the alert definition, Auvik doesn’t know where to send messages.

  1. From your Auvik dashboard, click Manage Alerts from the side navigation bar.
  2. Click Notification Channels.
  3. In the display list of notification channels, find the Opsgenie channel. Check the box at the beginning of its row.
  4. Click Associate with Alerts.
  5. Confirm that alerts appear to be associated (True). If there aren’t any associated alerts in the displayed list of alerts, find the one(s) you want to associate to the notification channel. Check the box at the beginning of each row.

 

During maintenance windows in Auvik, alerts still trigger but notifications are suppressed. Depending on where the maintenance window was originally created, you might need to check this from the global dashboard or the client dashboard. 

  1. From your Auvik dashboard, click Manage Alerts from the side navigation bar.
  2. Click Maintenance Windows.
  3. In the Configured Maintenance Windows grid, you can see if there’s an active maintenance window that matches the date and time the alert triggered.
  4. In the Maintenance History grid, you can see if there were any maintenance windows open during the date and time the alert triggered.

 

If you see a maintenance window that corresponds with the date and time of the triggered alert, you can send it to Opsgenie for tracking. To do this, see How do I resend notifications?

If everything looks good with the configuration in both Opsgenie and Auvik, and there weren’t any maintenance windows open but alerts still aren’t being sent from Auvik to Opsgenie, please contact Auvik support.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Auvik System Status

Check system status